Results 1 to 4 of 4
  1. #1
    Member gruni's Avatar
    Join Date
    Sep 2014
    Location
    None
    Posts
    24
    Vehicle
    Vectra C 1.9

    Vectra C CID communication / coding problem

    Hello everybody,

    i have a 2007 Vectra with a CID fitted. Unfortunately the CID does not have the BC tab activated and i am not able to activate it. When connecting to the CID with my trusty "plopcom" it takes a very long time to retrieve the information about model number, software date etc. The entries appear at a rate of about 4 to 5 seconds per line, so something must inhibit the display from communicating correctly. Therefore variant coding is not prossible, i get different errors when reading the current variant config, most of the times it says "not all DID readed correctly". Also, the programmed VIN can not be read. What does in fact work is set the time in the CID and changing of code index.

    Has anybody else experienced such a behaviour?

    Of course i would really like to activate the BC tab, so i thought about flashing a different image to the EEPROM. Would that work? I read online that the EEPROM content would be hardcoded to a specific display and would brick other units that the image would be flashed to?

    Thanks in advance


    • Advertising

      advertising
      Diagnostics.org.uk
      has no influence
      on advertisments
      that are displayed by
      Google Adsense

    • #2
      VIP+ soulman's Avatar
      Join Date
      Apr 2011
      Location
      Essex
      Posts
      1,161
      Vehicle
      Vectra
      that could work as mostly all vectra cid's use the same eprom, 93c66

      You would obviously need to 'pair' the display to your radio/uhp4 again so make sure you have the code for yours and that the file you put onto the display is actually tech2 clear.

      the very late displays were the 3line type with a different eprom/file size...

      The eproms are not locked to the display itself so is safe to put another one on...

    • #3
      Member gruni's Avatar
      Join Date
      Sep 2014
      Location
      None
      Posts
      24
      Vehicle
      Vectra C 1.9
      I decided to get a different CID off ebay instead. Unfortunately i can't get to it's variant coding either. Same error. So now at least i know that my display is not faulty.

      On my last Vectra i had no problem coding it's display, although i don't remember the exact type of the unit. My current displays both are id 0x1301 Identifier DB and software version D4.30/CE59... the display in my old Vectra most likely was also Identifier DB, maybe id 0x1201? Never any problem with that.

      Has anybody encountered similar problems and perhaps found a solution to this?

    • #4
      Member bank's Avatar
      Join Date
      Oct 2018
      Location
      Kyi
      Posts
      12
      Vehicle
      Zafira B
      The problem is in PC/OS or OPCOM/software/firmware

Similar Threads

  1. 2007 Vectra 2.2 Elite - CD70 - GPS Problem
    By kevj66 in forum Vectra
    Replies: 1
    Last Post: 8th August 2016, 05:50 PM
  2. vectra cdti immobiliser problem need help
    By paulygsi in forum Electrical
    Replies: 2
    Last Post: 23rd October 2013, 02:55 PM
  3. Vectra front demister (4) problem
    By Rid in forum Vectra
    Replies: 0
    Last Post: 15th May 2013, 08:03 PM

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!
SEO Blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
This site was created by Pecky to act as a knowledge base of useful information regarding Vauxhall cars.
Whilst I can help out with works, this isn't my full time job, so occasionally there may be a delay in replying.

Other forums

AOC, AON, VXR-Online, Insignia-drivers.uk

Diagnostics.org.uk is a trading name of RJP Projects Ltd which is a company registered in England and Wales with company number 7453778