Results 1 to 2 of 2
  1. #1
    Member samlord12345's Avatar
    Join Date
    Aug 2017
    Location
    GB
    Posts
    1
    Vehicle
    insignia cdti sri 160

    Any advice please

    Can i get some advice guys please i have a 09 sri insignia cdti and it sounds like i have a boost leak but i have changed both boost pipes that lead from the turbo to intercooler and from intercooler to engine but its still hissing and sounds like i have a blow off valve, i have lost alot of power and takes ages to boost , i have also changed the boost sensor but no luck

    Sent from my SM-G955F using Tapatalk

Similar Threads

  1. Bit of advice please! :(
    By Rob in forum Mechanical
    Replies: 26
    Last Post: 29th December 2013, 04:58 PM
  2. advice please
    By Taylor in forum Mechanical
    Replies: 8
    Last Post: 18th April 2012, 04:59 PM

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!
SEO Blog

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
About us
This site was created by Pecky to act as a knowledge base of useful information regarding Vauxhall cars.
Whilst I can help out with works, this isn't my full time job, so occasionally there may be a delay in replying.

Other forums

AOC, AON, VXR-Online, Insignia-drivers.uk

Diagnostics.org.uk is a trading name of RJP Projects Ltd which is a company registered in England and Wales with company number 7453778